Workbee CNC Bulkman3d komplekt - Huanyangi VFD

Proovin sellest aru saada. Kiire phpinfo () tegemisel saan:

PHP Version 7.1.14 System Linux gatorxxxxx.hostgator.com n.nn.nnn-nnn.nnn.nnn.x86_64 #1 SMP Tue May 21 13:24:40 CDT 2019 x86_64 

Kuid kui proovin installida croni, mis jõuab iga 30 päeva järel URL-ile automaatse installi-tasuta-SSL-i pistikprogrammi jaoks, mida olen aastaid kasutanud teises hostis, teatab cron:

Teie serveris töötab PHP versioon 5.4.45, kuid WordPress 5.3.2 nõuab vähemalt 5.6.20.

Sain Hostgatori telefoni teel ja nad teatasid, et kõik jagatud hostid on endiselt 5.4.x-s, mis sobib veateatega, kuid kui phpinfo () näitab, et ma olen 7.1-ga ... mis siin ikka toimub? Kuidas saada cron kasutama ka 7.1, et käsk täidetaks?

  • On võimalik, et teil on direktiiv sisse .htaccess (ja / või seadistage hostimiskeskuse kaudu), mis määrab teisele PHP-versioonile midagi muud kui teie serveris määratud vaikimisi (5.4).
  • Jah, see on võimalik, kuid see pole siin nii. Pidin lihtsalt rääkima cronile, mida kasutada, kuna mingil põhjusel on see vaikimisi alati serveri PHP madalaim versioon.

Olen avastanud, et saate määrata PHP versiooni, mida cron peaks kasutama nii:

/opt/php56/bin/php -q /home/userna5/public_html/testcron.php

tänu sellele õpetusele. Kõik töötab nüüd vastavalt soovile.

none: Charles Robertson | none