Üksi vaadates on versioone ja ühilduvust lihtne uurida. Versiooniteave on hõlpsasti kättesaadav platvormivirna igas osas, näiteks MySQL-is. Siit saate teada uusima versiooni, stabiilse versiooni ja mõnikord isegi selle kasutuselevõtjate protsendi versiooni järgi (mulle isiklikult meeldib numbreid lapsendamise määrade kohta).

Parima võimaliku versioonide segu leidmisel on mul aga raskem. Näiteks "kui kasutate MySQL 5.5, vajate PHP versiooni XX või uuemat."

Seda on veelgi raskem leevendada, kui viskate segusse kõrgema taseme platvormid nagu Drupal, Joomla jne.

Ma pean tõepoolest kasulikuks selliseid "nõustajaid" nagu installijad, näiteks Bitnami installijad.Kuid ma mõtlen alati, kas need lahendused sobivad pigem kõige vähem ühisele nimetajale - olgu kõik paljud - ja sellisena arvan, et parem oleks asjad ise installida. Sellised lahendused tunduvad uute versioonide kasutuselevõtmisel olevat aeglased, ma arvan, et aeglasem kui vaja.

Kas on olemas veebisait või tööriist, mis koondab versiooniandmed, et aidata veebimeistril valida, milliseid versioone juurutada või milliseid versiooniuuendusi installida, võttes arvesse virna kõiki muid osi?

Kas soovite allikat, mis näitab iga rakenduse uusimat praegust stabiilset versiooni? Kui jah, siis arvan, et selleks on pakettide haldurid.

Nii et vali lihtsalt oma valitud distro, nende veebisait peaks viima uusimale versioonile. Siis jookse apt-get/yum ja installige virna iga osa uusim stabiilne versioon. Või kui kasutate Ubuntu, võite seda lihtsalt kasutada tasksel AMP osa installimiseks ühe korraga.

Muuda: Ma arvan, et pole mingeid erilisi kaalutlusi (välja arvatud see, kas soovite PHP-d käivitada üle CGI või moodulina), mida peate nende pakettide jaoks tegema. WAMP-i virna installimine on veidi keerulisem, kuid Linuxil saate lihtsalt valida uusima stabiilse ja sellega koos töötada. PHP / MySQL-i ja teie veebirakenduste ühilduvusprobleemide korral peate võib-olla valima vanema talli.

  • +1, teil on õigus - nii palju kui ma eelistan, et mul oleks versiooniversioonide üle kontroll, on selle levitamine meie jaoks hõlpsam.
  • @Chris: Saate tegelikult luua oma yum (võib-olla ka apt) ka hoidlaserveri ja seda ise hallata. Kui jälgite ainult mõnda paketti, ei pruugi see olla liiga palju tööd. Kuigi see on rohkem kaasatud, on tõenäoliselt võimalik luua ka klient, mis kontrollib teie installitud rakenduste / raamistike ühilduvust iga korstna komponendiga. Ma näen, et see on veebimeistrite jaoks üsna kasulik.

none: Charles Robertson | none

none