Sublime Text 3 seadistamine - kõige olulisemad paketid

Ma ehitan WordPressi pistikprogrammi, mis on mõeldud laialdaseks väljaandmiseks ja tahaksin, et saaksin sellele tugineda openssl ja gmp laiendused, mis nõuavad, et PHP kompileeriti täpsustatud laienditega ja et need on sisse lülitatud php.ini. Ma tean, et saan kontrollida, kas laiendused on laaditud, ja vea, kui ei, ja tean, et nutikad kasutajad saavad laienduse käsitsi lubada ja mittetarkad, kuid motiveeritud kasutajad võiksid paluda oma veebihalduril need lubada, kuid ma sooviksin nagu maksimaalne ühilduvus väravast väljas.

Ma tean, et see ei ole 100% hostidest, kuid ma oleksin rahul 90% või isegi "jah enamusega neist", kuid ma ei leia ühtegi viisi, kuidas mõista, millised laiendused on tavaliselt saadaval. Tean vaid seda, et nii minu HostGatori kui ka Pantheoni saidil on openssl ja gmp lubatud, kuid sellel on vaikimisi installitud php7 arch linuxil openssl kuid mitte gmp.

Vastavalt https://wordpress.stackexchange.com/a/42212/41534 ja https://github.com/johnbillion/ext openssl on WordPressi poolt nõutav ainult PHPMailerja gmp pole nõutav, seega tundub tõenäoline, kuid pole kindel, et WordPressi toetavad hostid seda lubavad openssl, aga ei tea gmp. WordPress nõuab siiski PHP versiooni 7.3 või uuemat, seega eeldan, et vähemalt.

Kuid lisaks nendele kahele konkreetsele laiendusele oleks tore, kui teil oleks mingisugune viis üldise ülevaate saamiseks sellest, mida tavaliselt lubatakse, kuigi täiuslikku vastust ei tule.

none: Charles Robertson | none