Minu hostimisserveril on php 5.4.45 installitud koos mysql 5.6.28-76.1 cpanel 58.0 (build 47)

Mul on nii palju vigu, kuna kasutasin arvutis uusimat XAMPP-i koos PHP 7.1-ga. Ma tahan olla oma serveriga sünkroonis.

Esitage mulle üksikasjad, kust leiate XAMPP-i ühilduva versiooni, mis lahendab minu probleemi.

Tundub, et viimane XAMPP-i versioon, mis põhineb PHP 5.4-l, oli XAMPP 1.8.2-x seeria, mis tipnes versiooniga 1.8.2-6.

Kuid tundub ka, et 1.8.2 seerias kasutati MySQL 5.5, mitte 5.6. Esimene XAMPP versioon, mis seda tegi, näib olevat olnud 1.8.3-x, kusjuures selle seeria lõplik versioon on 1.8.3-5.

Mõlemad on laialdaselt kättesaadavad erinevatel saitidel, mis on spetsialiseerunud tarkvara vanematele versioonidele, näiteks OldApps.com.

Nagu väike märkus - kui kumbki neist ei rahulda teie vajadusi, saate teha natuke jalgadega tööd ja seadistada kõik kolm üsna hõlpsasti ilma XAMPP-i vajada.

none: Charles Robertson | none